<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-GB">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-GB">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-GB">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-GB">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="pingback" href="https://zwnews.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://zwnews.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->
<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<script>var et_site_url='https://zwnews.com';var et_post_id='44924';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>Enough is enough, 2020 a year of Action: Nelson Chamisa | ZIM NEWS | ZwNews | LATEST ZIMBABWE NEWS TODAY 24 7| Zim Latest News</title>

<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Enough is enough, 2020 a year of Action: Nelson Chamisa | ZIM NEWS | ZwNews | LATEST ZIMBABWE NEWS TODAY 24 7| Zim Latest News" />
<meta property="og:description" content="Main opposition MDC Alliance leader, Nelson Chamisa has boldly claimed that 2020 is a &#8216;year of action&#8217; against the long-ruling Zanu PF Government and party leader, President Emmerson Mnangagwa. In his hyped State of the Nation Address Tuesday, the youthful MDC leader called for &#8216;action&#8217; , saying: &#8216;Enough is enough&#8217;. &#8220;The people have spoken enough &hellip;" />
<meta property="og:url" content="https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/" />
<meta property="og:site_name" content="ZIM NEWS | ZwNews | LATEST ZIMBABWE NEWS TODAY 24 7| Zim Latest News" />
<meta property="article:publisher" content="https://www.facebook.com/Zimbabwe.News.24.Zim.Latest.Update.Mugabe.Today/" />
<meta property="article:section" content="Zim Latest" />
<meta property="article:published_time" content="2020-01-21T21:37:09+00:00" />
<meta property="og:image" content="https://i1.wp.com/zwnews.com/wp-content/uploads/2019/07/chamisa-pastor-1200x600.jpg?fit=1200%2C600&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i1.wp.com/zwnews.com/wp-content/uploads/2019/07/chamisa-pastor-1200x600.jpg?fit=1200%2C600&#038;ssl=1" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="600" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Main opposition MDC Alliance leader, Nelson Chamisa has boldly claimed that 2020 is a &#8216;year of action&#8217; against the long-ruling Zanu PF Government and party leader, President Emmerson Mnangagwa. In his hyped State of the Nation Address Tuesday, the youthful MDC leader called for &#8216;action&#8217; , saying: &#8216;Enough is enough&#8217;. &#8220;The people have spoken enough [&hellip;]" />
<meta name="twitter:title" content="Enough is enough, 2020 a year of Action: Nelson Chamisa | ZIM NEWS | ZwNews | LATEST ZIMBABWE NEWS TODAY 24 7| Zim Latest News" />
<meta name="twitter:site" content="@ZimbabwesNews" />
<meta name="twitter:image" content="https://i1.wp.com/zwnews.com/wp-content/uploads/2019/07/chamisa-pastor-1200x600.jpg?fit=1200%2C600&#038;ssl=1" />
<meta name="twitter:creator" content="@ZimbabwesNews" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://zwnews.com/#website","url":"https://zwnews.com/","name":"ZIM NEWS | ZwNews | LATEST ZIMBABWE NEWS TODAY 24 7| Zim Latest News","description":"Zimbabwe  News  Headlines Now,  Breaking Top Stories From Live News Updates in Zimbabwe, www.zimbabwenews, Newspapers online","potentialAction":{"@type":"SearchAction","target":"https://zwnews.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/#primaryimage","url":"https://i1.wp.com/zwnews.com/wp-content/uploads/2019/07/chamisa-pastor-1200x600.jpg?fit=1200%2C600&ssl=1","width":1200,"height":600},{"@type":"WebPage","@id":"https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/#webpage","url":"https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/","inLanguage":"en-GB","name":"Enough is enough, 2020 a year of Action: Nelson Chamisa | ZIM NEWS | ZwNews | LATEST ZIMBABWE NEWS TODAY 24 7| Zim Latest News","isPartOf":{"@id":"https://zwnews.com/#website"},"primaryImageOfPage":{"@id":"https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/#primaryimage"},"datePublished":"2020-01-21T21:37:09+00:00","dateModified":"2020-01-21T21:37:09+00:00","author":{"@id":"https://zwnews.com/#/schema/person/9c4fa154afb1c86d5409869b059acc28"},"breadcrumb":{"@id":"https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/#breadcrumb"}},{"@type":"BreadcrumbList","@id":"https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://zwnews.com/","url":"https://zwnews.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/","url":"https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/","name":"Enough is enough, 2020 a year of Action: Nelson Chamisa"}}]},{"@type":["Person"],"@id":"https://zwnews.com/#/schema/person/9c4fa154afb1c86d5409869b059acc28","name":"Tawanda Sibanda","image":{"@type":"ImageObject","@id":"https://zwnews.com/#authorlogo","url":"https://secure.gravatar.com/avatar/3e8f4e589fa04b9597d5e985a4f861c1?s=96&d=mm&r=g","caption":"Tawanda Sibanda"},"sameAs":[]}]}</script>

<link rel="amphtml" href="https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/amp/" /><meta name="generator" content="AMP for WP 1.0.15" /><link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ZIM NEWS | ZwNews | LATEST ZIMBABWE NEWS TODAY 24 7| Zim Latest News &raquo; Feed" href="https://zwnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="ZIM NEWS | ZwNews | LATEST ZIMBABWE NEWS TODAY 24 7| Zim Latest News &raquo; Comments Feed" href="https://zwnews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="ZIM NEWS | ZwNews | LATEST ZIMBABWE NEWS TODAY 24 7| Zim Latest News &raquo; Enough is enough, 2020 a year of Action: Nelson Chamisa Comments Feed" href="https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/zwnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<meta content="Extra v.4.0.11" name="generator" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style>
<link rel='stylesheet' id='extra-style-css' href='https://zwnews.com/wp-content/themes/Extra/style.css?ver=4.0.11' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://zwnews.com/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://zwnews.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://zwnews.com/wp-content/cache/asset-cleanup/css/item/jetpack_css-v8.1-77132b81ea245c1f7473a51255d62e3ab470b90f.css' type='text/css' media='all' />
<script type='text/javascript' src='https://zwnews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://zwnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var et_core_api_spam_recaptcha = {"site_key":"","page_action":{"action":"enoughisenough2020ayearofactionnelsonchamisa"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://zwnews.com/wp-content/themes/Extra/core/admin/js/recaptcha.js?ver=5.3.2'></script>
<link rel='https://api.w.org/' href='https://zwnews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://zwnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://zwnews.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://wp.me/p7efUq-bGA' />
<link rel="alternate" type="application/json+oembed" href="https://zwnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fzwnews.com%2Fenough-is-enough-2020-a-year-of-action-nelson-chamisa%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://zwnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fzwnews.com%2Fenough-is-enough-2020-a-year-of-action-nelson-chamisa%2F&#038;format=xml" />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//zwnews.com/?wordfence_lh=1&hid=EC3226D44140293B6076EBF4C763AD6B');
</script>
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<style type='text/css'>img#wpstats{display:none}</style><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script>
<link rel="icon" href="https://i1.wp.com/zwnews.com/wp-content/uploads/2016/09/latest-update-zimbabwe-newspapers-zim-news-zimnewsnet.jpg?fit=30%2C21&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/zwnews.com/wp-content/uploads/2016/09/latest-update-zimbabwe-newspapers-zim-news-zimnewsnet.jpg?fit=30%2C21&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i1.wp.com/zwnews.com/wp-content/uploads/2016/09/latest-update-zimbabwe-newspapers-zim-news-zimnewsnet.jpg?fit=30%2C21&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/zwnews.com/wp-content/uploads/2016/09/latest-update-zimbabwe-newspapers-zim-news-zimnewsnet.jpg?fit=30%2C21&#038;ssl=1" />
<link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://zwnews.com/wp-content/et-cache/global/et-extra-customizer-global-15796422125965.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /></head>
<body data-rsssl=1 class="post-template-default single single-post postid-44924 single-format-standard et_extra et_fullwidth_secondary_nav et_fixed_nav boxed_layout et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
<div id="page-container" class="page-container">

<header class="header left-right">

<div id="top-header" style="">
<div class="container">

<div id="et-secondary-nav" class="">
<ul id="et-secondary-menu" class="nav"><li id="menu-item-44352" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44352"><a href="https://zwnews.com/business/">Business</a></li>
<li id="menu-item-44353" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44353"><a href="https://zwnews.com/opinion/">Opinion</a></li>
<li id="menu-item-44354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44354"><a href="https://zwnews.com/health/">Health</a></li>
<li id="menu-item-44356" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44356"><a href="https://zwnews.com/education/">Education</a></li>
<li id="menu-item-44453" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44453"><a href="https://zwnews.com/letters/">Letters</a></li>
<li id="menu-item-44360" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44360"><a href="https://zwnews.com/education-life/">Books, Life &#038; Education</a></li>
<li id="menu-item-44377" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44377"><a href="https://zwnews.com/about/">About</a></li>
<li id="menu-item-44359" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44359"><a href="https://zwnews.com/technology/">Technology</a></li>
<li id="menu-item-44378" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44378"><a href="https://zwnews.com/privacy-policy/">Privacy Policy</a></li>
</ul> </div>

<div id="et-info">

<div class="et-top-search" style="">
<form role="search" class="et-search-form" method="get" action="https://zwnews.com/">
<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
<button class="et-search-submit"></button>
</form> </div>

</div>
</div>
</div>

<div id="main-header-wrapper">
<div id="main-header" data-fixed-height="118">
<div class="container">


<a class="logo" href="https://zwnews.com/" data-fixed-height="28">
<img src="https://zwnews.com/wp-content/uploads/2018/04/zwnews-zimbabwe-2.png" alt="ZIM NEWS | ZwNews | LATEST ZIMBABWE NEWS TODAY 24 7| Zim Latest News" id="logo" />
</a>

<div id="et-navigation" class="">
<ul id="et-menu" class="nav"><li id="menu-item-7803" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7803"><a href="https://zwnews.com/latest-zimbabwe-news/">Latest</a></li>
<li id="menu-item-44369" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44369"><a href="https://zwnews.com/sport/">Sport</a></li>
<li id="menu-item-44368" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44368"><a href="https://zwnews.com/world/">World &#038; Africa</a></li>
<li id="menu-item-44370" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44370"><a href="https://zwnews.com/videos/">Videos</a></li>
<li id="menu-item-29017" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29017"><a href="https://zwnews.com/zimbabwe-news-whatsapp-mobile-phone-numbers-email-us-contact/">Contact Us</a></li>
</ul> <div id="et-mobile-navigation">
<span class="show-menu">
<div class="show-menu-button">
<span></span>
<span></span>
<span></span>
</div>
<p>Select Page</p>
</span>
<nav>
</nav>
</div>  </div>
</div>
</div>
</div>
</header>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<article id="post-44924" class="module single-post-module post-44924 post type-post status-publish format-standard has-post-thumbnail hentry category-latest-zimbabwe-news et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">Enough is enough, 2020 a year of Action: Nelson Chamisa</h1>
<div class="post-meta vcard">
<p><span class="updated">Jan 22, 2020</span> | <a href="https://zwnews.com/latest-zimbabwe-news/" rel="tag">Zim Latest</a></p>
</div>
</div>
<div class="post-thumbnail header">
<img src="https://i1.wp.com/zwnews.com/wp-content/uploads/2019/07/chamisa-pastor-1200x600.jpg?resize=1200%2C600&amp;ssl=1" alt="Enough is enough, 2020 a year of Action: Nelson Chamisa" /> </div>
<div class="et_pb_extra_row etad post_above">
<div class="adsense-responsive-ad"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-8508699359762977" data-ad-slot="1484010644"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<p>Main opposition MDC Alliance leader, Nelson Chamisa has boldly claimed that 2020 is a &#8216;year of action&#8217; against the long-ruling Zanu PF Government and party leader, President Emmerson Mnangagwa.<br />
In his hyped State of the Nation Address Tuesday, the youthful MDC leader called for &#8216;action&#8217; , saying: &#8216;Enough is enough&#8217;.<br />
&#8220;The people have spoken enough about and against this scourge which has come about at the expense of their destroyed livelihoods. Enough is enough. This year, in 2020, the people will speak through action, against the scourge and in defence of their right to their livelihoods, which they must now begin to reconstruct for themselves and their families&#8221;, Chamisa said.<br />
Chamisa also said his party is contemplating taking its disgruntlement over the &#8216;stolen&#8217; 2018 elections to the African Court on Human and People&#8217;s Rights.<br />
&#8220;There’s also now a clear and present basis for taking the matter of the 2018 presidential election to the African Court on Human and Peoples Rights. Such actions would be well within the BBI, as an expression of the people’s action to restore legality and legitimacy under the MDC’s Agenda 2020&#8221;.<br />
Various opinion leaders and political commentators have accused Chamisa of being a motor-mouth politician who lacks the capabilities of confronting the Mnangagwa regime.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-44924" class="share-pinterest sd-button share-icon no-text" href="https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-44924" class="share-facebook sd-button share-icon no-text" href="https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-44924" class="share-twitter sd-button share-icon no-text" href="https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div> </div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
<a href="#" class="social-share-link" title="Share &quot;Enough is enough, 2020 a year of Action: Nelson Chamisa&quot; via Email" data-network-name="basic_email" data-share-title="Enough is enough, 2020 a year of Action: Nelson Chamisa" data-share-url="https://zwnews.com/enough-is-enough-2020-a-year-of-action-nelson-chamisa/">
<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span>
</a> </div>
<style type="text/css" id="rating-stars">.post-footer .rating-stars #rated-stars img.star-on,.post-footer .rating-stars #rating-stars img.star-on{background-color:#00A8FF}</style>
</div>
<div class="et_pb_extra_row etad post_below">
<div class="adsense-responsive-ad"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-8508699359762977" data-ad-slot="3982595449"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div> </div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="https://zwnews.com/netizens-savage-photoshoot-minister-mthuli-ncube/" rel="prev"><span class="button">Previous</span><span class="title">&#8216;Netizens&#8217; savage &#8216;photoshoot Minister&#8217; Mthuli Ncube</span></a> </div>
<div class="nav-link nav-link-next">
</div>
</div>
</nav>
</div>
<div class="et_pb_extra_column_sidebar">
<div id="top-posts-3" class="et_pb_widget widget_top-posts"><h4 class="widgettitle">Top Headlines</h4><ul class='widgets-list-layout no-grav'>
<li>
<a href="https://zwnews.com/whats-wrong-with-these-pictures-president-chiwenga-driven-around-by-mnangagwa/" title="Whats wrong with these pictures: President Chiwenga driven by Mnangagwa..Begging kids?" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i0.wp.com/zwnews.com/wp-content/uploads/2020/01/ed-chiwenga-in-car.jpg?fit=912%2C684&#038;ssl=1&#038;resize=40%2C40" alt="Whats wrong with these pictures: President Chiwenga driven by Mnangagwa..Begging kids?" data-pin-nopin="true" class="widgets-list-layout-blavatar" />
</a>
<div class="widgets-list-layout-links">
<a href="https://zwnews.com/whats-wrong-with-these-pictures-president-chiwenga-driven-around-by-mnangagwa/" title="Whats wrong with these pictures: President Chiwenga driven by Mnangagwa..Begging kids?" class="bump-view" data-bump-view="tp">Whats wrong with these pictures: President Chiwenga driven by Mnangagwa..Begging kids?</a>
</div>
</li>
<li>
<a href="https://zwnews.com/marry-mubaiwa-rejects-chiwenga-out-of-court-offer/" title="Marry rejects Chiwenga out of court settlement offer...To expose Walter Magaya dirty secret" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i1.wp.com/zwnews.com/wp-content/uploads/2020/01/marry-chiwenga-latest.jpg?fit=900%2C704&#038;ssl=1&#038;resize=40%2C40" alt="Marry rejects Chiwenga out of court settlement offer...To expose Walter Magaya dirty secret" data-pin-nopin="true" class="widgets-list-layout-blavatar" />
</a>
<div class="widgets-list-layout-links">
<a href="https://zwnews.com/marry-mubaiwa-rejects-chiwenga-out-of-court-offer/" title="Marry rejects Chiwenga out of court settlement offer...To expose Walter Magaya dirty secret" class="bump-view" data-bump-view="tp">Marry rejects Chiwenga out of court settlement offer...To expose Walter Magaya dirty secret</a>
</div>
</li>
<li>
<a href="https://zwnews.com/preymore-dube-zimbabwean-cop-killer-arrested-in-south-africa-more-details-pictures/" title="Preymore Dube: Zimbabwean cop killer arrested in South Africa..more details..PICTURES" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i0.wp.com/zwnews.com/wp-content/uploads/2020/01/preymore-dube-latest-news-gun.jpg?fit=480%2C640&#038;ssl=1&#038;resize=40%2C40" alt="Preymore Dube: Zimbabwean cop killer arrested in South Africa..more details..PICTURES" data-pin-nopin="true" class="widgets-list-layout-blavatar" />
</a>
<div class="widgets-list-layout-links">
<a href="https://zwnews.com/preymore-dube-zimbabwean-cop-killer-arrested-in-south-africa-more-details-pictures/" title="Preymore Dube: Zimbabwean cop killer arrested in South Africa..more details..PICTURES" class="bump-view" data-bump-view="tp">Preymore Dube: Zimbabwean cop killer arrested in South Africa..more details..PICTURES</a>
</div>
</li>
<li>
<a href="https://zwnews.com/watch-live-video-updates-mdc-nelson-chamisa-state-of-the-nation-address-sona-mbare-harare-today-pictures/" title="WATCH LIVE VIDEO UPDATES: MDC Nelson Chamisa State of the Nation Address-SONA, Mbare, Harare Today..PICTURES" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i1.wp.com/zwnews.com/wp-content/uploads/2018/04/mdc-rally-chipinge.jpg?fit=937%2C619&#038;ssl=1&#038;resize=40%2C40" alt="WATCH LIVE VIDEO UPDATES: MDC Nelson Chamisa State of the Nation Address-SONA, Mbare, Harare Today..PICTURES" data-pin-nopin="true" class="widgets-list-layout-blavatar" />
</a>
<div class="widgets-list-layout-links">
<a href="https://zwnews.com/watch-live-video-updates-mdc-nelson-chamisa-state-of-the-nation-address-sona-mbare-harare-today-pictures/" title="WATCH LIVE VIDEO UPDATES: MDC Nelson Chamisa State of the Nation Address-SONA, Mbare, Harare Today..PICTURES" class="bump-view" data-bump-view="tp">WATCH LIVE VIDEO UPDATES: MDC Nelson Chamisa State of the Nation Address-SONA, Mbare, Harare Today..PICTURES</a>
</div>
</li>
<li>
<a href="https://zwnews.com/pictures-video-inside-the-beautiful-new-air-zimbabwe-plane-for-london-and-beijing-routes/" title="Pictures..video: Inside the beautiful new Air Zimbabwe plane for London and Beijing routes" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i2.wp.com/zwnews.com/wp-content/uploads/2020/01/airzim5.jpg?fit=1024%2C497&#038;ssl=1&#038;resize=40%2C40" alt="Pictures..video: Inside the beautiful new Air Zimbabwe plane for London and Beijing routes" data-pin-nopin="true" class="widgets-list-layout-blavatar" />
</a>
<div class="widgets-list-layout-links">
<a href="https://zwnews.com/pictures-video-inside-the-beautiful-new-air-zimbabwe-plane-for-london-and-beijing-routes/" title="Pictures..video: Inside the beautiful new Air Zimbabwe plane for London and Beijing routes" class="bump-view" data-bump-view="tp">Pictures..video: Inside the beautiful new Air Zimbabwe plane for London and Beijing routes</a>
</div>
</li>
<li>
<a href="https://zwnews.com/mnangagwa-wants-to-stay-in-power-views-chiwenga-as-totally-unsuited-to-be-his-successor/" title="&quot;Mnangagwa wants to stay in power, Views Chiwenga as totally unsuited to be his successor&quot;" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i2.wp.com/zwnews.com/wp-content/uploads/2020/01/mnangagwa-chiwenga-friends-or-not.jpg?fit=720%2C540&#038;ssl=1&#038;resize=40%2C40" alt="&quot;Mnangagwa wants to stay in power, Views Chiwenga as totally unsuited to be his successor&quot;" data-pin-nopin="true" class="widgets-list-layout-blavatar" />
</a>
<div class="widgets-list-layout-links">
<a href="https://zwnews.com/mnangagwa-wants-to-stay-in-power-views-chiwenga-as-totally-unsuited-to-be-his-successor/" title="&quot;Mnangagwa wants to stay in power, Views Chiwenga as totally unsuited to be his successor&quot;" class="bump-view" data-bump-view="tp">&quot;Mnangagwa wants to stay in power, Views Chiwenga as totally unsuited to be his successor&quot;</a>
</div>
</li>
<li>
<a href="https://zwnews.com/zimbabwe-money-exchange-rates-today-20-01-20/" title="Zimbabwe money exchange rates today: 20-01-20" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i0.wp.com/zwnews.com/wp-content/uploads/2017/09/zimbabwe-cash-crises.jpg?fit=818%2C710&#038;ssl=1&#038;resize=40%2C40" alt="Zimbabwe money exchange rates today: 20-01-20" data-pin-nopin="true" class="widgets-list-layout-blavatar" />
</a>
<div class="widgets-list-layout-links">
<a href="https://zwnews.com/zimbabwe-money-exchange-rates-today-20-01-20/" title="Zimbabwe money exchange rates today: 20-01-20" class="bump-view" data-bump-view="tp">Zimbabwe money exchange rates today: 20-01-20</a>
</div>
</li>
<li>
<a href="https://zwnews.com/photos-of-sa-south-african-police-hunt-zimbabwean-national-preymore-dube-who-killed-cop-captain-oupa-matjie-of-diepsloot-saps-soweto/" title="SA police hunt Zim man Preymore Dube who killed cop Captain Oupa Matjie of Diepsloot SAPS..PICTURES" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i2.wp.com/zwnews.com/wp-content/uploads/2020/01/preymore-dube-wanted-sa-police-guns.jpg?fit=526%2C936&#038;ssl=1&#038;resize=40%2C40" alt="SA police hunt Zim man Preymore Dube who killed cop Captain Oupa Matjie of Diepsloot SAPS..PICTURES" data-pin-nopin="true" class="widgets-list-layout-blavatar" />
</a>
<div class="widgets-list-layout-links">
<a href="https://zwnews.com/photos-of-sa-south-african-police-hunt-zimbabwean-national-preymore-dube-who-killed-cop-captain-oupa-matjie-of-diepsloot-saps-soweto/" title="SA police hunt Zim man Preymore Dube who killed cop Captain Oupa Matjie of Diepsloot SAPS..PICTURES" class="bump-view" data-bump-view="tp">SA police hunt Zim man Preymore Dube who killed cop Captain Oupa Matjie of Diepsloot SAPS..PICTURES</a>
</div>
</li>
<li>
<a href="https://zwnews.com/james-makamba-in-serious-trouble/" title="James Makamba in serious trouble" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i0.wp.com/zwnews.com/wp-content/uploads/2018/06/james-makamba.jpg?fit=1039%2C859&#038;ssl=1&#038;resize=40%2C40" alt="James Makamba in serious trouble" data-pin-nopin="true" class="widgets-list-layout-blavatar" />
</a>
<div class="widgets-list-layout-links">
<a href="https://zwnews.com/james-makamba-in-serious-trouble/" title="James Makamba in serious trouble" class="bump-view" data-bump-view="tp">James Makamba in serious trouble</a>
</div>
</li>
<li>
<a href="https://zwnews.com/if-mugabe-was-around-mashurugwi-will-be-history-stanley-goreraza/" title="If Mugabe was around, MaShurugwi will be history: Stanley Goreraza" class="bump-view" data-bump-view="tp">
<img width="40" height="40" src="https://i2.wp.com/zwnews.com/wp-content/uploads/2016/09/mugabe-cio-website-bonongwe-chiwenga-spies.jpg?fit=728%2C500&#038;ssl=1&#038;resize=40%2C40" alt="If Mugabe was around, MaShurugwi will be history: Stanley Goreraza" data-pin-nopin="true" class="widgets-list-layout-blavatar" />
</a>
<div class="widgets-list-layout-links">
<a href="https://zwnews.com/if-mugabe-was-around-mashurugwi-will-be-history-stanley-goreraza/" title="If Mugabe was around, MaShurugwi will be history: Stanley Goreraza" class="bump-view" data-bump-view="tp">If Mugabe was around, MaShurugwi will be history: Stanley Goreraza</a>
</div>
</li>
</ul>
</div> <div id="media_image-3" class="et_pb_widget widget_media_image"><h4 class="widgettitle">Follow Us On Facebook</h4><a href="https://www.facebook.com/Zim.News.Net.Zimbabwe/"><img width="300" height="132" src="https://i1.wp.com/zwnews.com/wp-content/uploads/2019/10/zimbabwe-zim-news-latest-on-facebook-.png?fit=300%2C132&amp;ssl=1" class="image wp-image-41302  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://i1.wp.com/zwnews.com/wp-content/uploads/2019/10/zimbabwe-zim-news-latest-on-facebook-.png?w=305&amp;ssl=1 305w, https://i1.wp.com/zwnews.com/wp-content/uploads/2019/10/zimbabwe-zim-news-latest-on-facebook-.png?resize=300%2C132&amp;ssl=1 300w" sizes="(max-width: 300px) 100vw, 300px" /></a></div> <div id="media_image-2" class="et_pb_widget widget_media_image"><h4 class="widgettitle">Follow On Twitter</h4><a href="https://twitter.com/ZwNews_"><img width="300" height="162" src="https://i0.wp.com/zwnews.com/wp-content/uploads/2019/10/zwnews-twitter.jpg?fit=300%2C162&amp;ssl=1" class="image wp-image-41127  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://i0.wp.com/zwnews.com/wp-content/uploads/2019/10/zwnews-twitter.jpg?w=305&amp;ssl=1 305w, https://i0.wp.com/zwnews.com/wp-content/uploads/2019/10/zwnews-twitter.jpg?resize=300%2C162&amp;ssl=1 300w" sizes="(max-width: 300px) 100vw, 300px" /></a></div> <div id="eu_cookie_law_widget-2" class="et_pb_widget widget_eu_cookie_law_widget"><div class="hide-on-button" data-hide-timeout="30" data-consent-expiration="180" id="eu-cookie-law">
<form method="post">
<input type="submit" value="Close and accept" class="accept" />
</form>
Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
<a href="https://zwnews.com/privacy-policy/">
Cookie Policy	</a>
</div>
</div> </div>
</div> 
</div> 
</div> 
<footer id="footer" class="footer_columns_4">
<div id="footer-bottom">
<div class="container">

<p id="footer-info">Designed by <a href="https://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="https://www.wordpress.org">WordPress</a></p>

<div id="footer-nav">
<ul class="et-extra-social-icons" style="">
</ul>
</div> 
</div>
</div>
</footer>
</div> 
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/zwnews.com\/enough-is-enough-2020-a-year-of-action-nelson-chamisa\/":44924};
	</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-84293971-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-84293971-1');
</script>
<amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-8508699359762977" data-ad-slot="2888529164" data-auto-format="rspv" data-full-width="">
<div overflow=""></div>
</amp-ad>
<script type='text/javascript' src='https://zwnews.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001'></script>
<script type='text/javascript' src='https://zwnews.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/zwnews.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/zwnews.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"424af0a593","timeline_nonce":"76909d1b75","blog_feed_nonce":"3499b2584a","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"yes"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/zwnews.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/zwnews.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/zwnews.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"b48b7bdb0a","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"397cd1349f","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","ab_tests":[],"is_ab_testing_active":"","page_id":"44924","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"yes","is_shortcode_tracking":"","tinymce_uri":""}; var et_frontend_scripts = {"builderCssContainerPrefix":"#et-boc","builderCssLayoutPrefix":"#et-boc .et-l"};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://zwnews.com/wp-content/themes/Extra/scripts/scripts.min.js?ver=4.0.11'></script>
<script type='text/javascript' src='https://zwnews.com/wp-content/plugins/jetpack/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js?ver=20180522'></script>
<script type='text/javascript' src='https://zwnews.com/wp-content/themes/Extra/core/admin/js/common.js?ver=4.0.11'></script>
<script type='text/javascript' src='https://zwnews.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://zwnews.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=8.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202004.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.1',blog:'106832102',post:'44924',tz:'5',srv:'zwnews.com'} ]);
	_stq.push([ 'clickTrackerInit', '106832102', '44924' ]);
</script>
</body>
</html>
